読者です 読者をやめる 読者になる 読者になる

git clone できない[fatal: Unable to find remote helper for 'https']

gitのインストール時に(lib)curl-devel ライブラリを読みこめていないことが問題

対応

  • git 削除
$sudo yum remove git
  • 必要パッケージのインストール
$ sudo yum install curl-devel expat-devel gettext-devel   openssl-devel zlib-devel
  • ソースのダウンロード
wget https://git-core.googlecode.com/files/git-1.8.5.3.tar.gz
$ tar -zxf git-1.8.5.3.tar.gz
$ cd git-1.8.5.3
$ make prefix=/usr/local all
$ sudo make prefix=/usr/local install

再度cloneにすれば治るはず